読者です 読者をやめる 読者になる 読者になる

ルーティング定義時の変数名のアレ

get "/users/:id" => "users#show"
get "/users/:user_id/recipes" => "user_recipes#index"

というコードたまにあると思うんですが、「URLのパスを元にUserを取得する」という処理を共通化することを考えると、

get "/users/:user_id" => "users#show"
get "/users/:user_id/recipes" => "user_recipes#index"

のように「同種の変数に対しては同じ変数名を割り当てる」というルールを設けたほうが便利。